iOS Build a Vending Machine App in Swift Modeling An Interface Starter File Walkthrough

Guillermo Tame
Guillermo Tame
15,880 Points

Swift Version Incompatible

I downloaded the starter files but my new version of XCode is incompatible with swift version 3.

3 Answers

Hey,

Go to Vending Machine project –> Build Settings -> Basic –> Swift Compiler language and change from Swift 3 to Swift 4

Waylan Sands
PRO
Waylan Sands
Pro Student 5,273 Points

You may also have to select the app from TARGETS and change to Swift 5 etc