Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

WordPress Setup Your Local Development Environment

The WordPress Setup & Command in The Teachers Notes Aren't Working

Hey guys,

I am stuck and I am not sure if I have done something wrong.

When I initially went through the video, the command prompt told me that the command wasn't an external or internal command and now (as you can see from this screenshot: https://gyazo.com/261e2bfb3c5ac5d5cafcb651d7bb1f00) it's telling me that it can't find the path.

Next, I am not sure if it's because of the first issue but the WordPress setup page that's supposed to work at localhost/WordPress isn't working (Screenshot: https://gyazo.com/65bebc1ef67ac1a33976593cb0f4c9a2).

Would love some help on this. Sorry, I am new to this all.

1 Answer

Austin Whipple
Austin Whipple
29,687 Points

Hi Anthony,

First, it looks like those command prompt screenshots you're posting are to reset your MySQL password. Unless you've been specifically instructed to do so, I wouldn't attempt to change those. If you need to, check out this documentation from MAMP to do so.

For more help setting up WordPress and MAMP, definitely give that WPMUDev article a read. And if MAMP proves to be too big of a pain, there are tools like Local by FlyWheel that can help speed up the process.

Okay,

Thanks for the help (and the quick response) I will try these out ASAP and get back to you.