Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

JavaScript Setting Up Google Chrome for Node.js Debugging

Chienchia Chien
Chienchia Chien
4,166 Points

There is no "Node debugging" checkbox in my Chrome?

My environment details are below OS : MS Windows7 Node.js : 6.9.5 Chrome : Version 57.0.2987.98

I follow the step in this course, and after six "shift", many hidden checkboxes appear, but there is no "Node debugging", Does anyone know the reason?

My screenshot is in the link : https://goo.gl/wFOwyu

6 Answers

Seven Gam
seal-mask
PLUS
.a{fill-rule:evenodd;}techdegree
Seven Gam
Full Stack JavaScript Techdegree Student 142 Points

Hi Chien,

With Chrome 57. You don't need enable 'Node debugging' in Develop Tool.

Run: node --inspect ...

open address with chrome-devtools://devtools/remote/serve_file...

It work with me.

Chienchia Chien
Chienchia Chien
4,166 Points

Hi Seven,

Thank you, it works!

I had the same question as Carlos Braga and Akash Sharma. Looks like the behaviors of both node and chrome have changed a lot since the recording. I wish I could tag Andrew. :cry::cry:

Quite amazingly, this post on medium works just fine for me. Thank you, Owa Aquino.

Owa Aquino
Owa Aquino
19,277 Points

Hi Chienchia,

You'll need to install the latest node on your unit first to be able to use the Node Debugging tool.

Check out how to install here: https://medium.com/@paul_irish/debugging-node-js-nightlies-with-chrome-devtools-7c4a1b95ae27#.jwm0769nt

Cheers!

Owa

Chienchia Chien
Chienchia Chien
4,166 Points

Hi Owa, I am not sure I got your point. The course said Node.js version should be 6.4+. My previous node version is 6.9.5. Now I update it to 7.7.2 as you suggested (I guess...). But I still cannot see the "node debugging" checkbox. My node is installed at C:\Program Files\nodejs Does it mean that my Chrome doesn't know my node?

Thank you.

Carlos Braga
Carlos Braga
13,587 Points

Could anyone let me know please how to access the link below to debug it? Debugger listening on ws://127.0.0.1:9229/3ea5f476-2c05-4dbb-86d8-cd553b8506f9

Jaya Babu
Jaya Babu
12,982 Points

Hi Carlos, Go to chrome://inspect. Click the link 'Open dedicated DevTools for Node', and you will be redirected to Developer Tools for Node.js.

Andrii Kodola
seal-mask
.a{fill-rule:evenodd;}techdegree
Andrii Kodola
Full Stack JavaScript Techdegree Student 16,870 Points

A small correction. Seems like you don't have to go to 'Open dedicated DevTools for Node' after chrome://inspect, but click the link with Node.js icon.

Zane Chandy
seal-mask
.a{fill-rule:evenodd;}techdegree seal-36
Zane Chandy
Full Stack JavaScript Techdegree Graduate 19,328 Points

Hey everyone.

If you are reading this, chances are the information in the video is completely out-of-date in terms of running the node debugger in Chrome. An alternative way to use the node debugger is to:

1) Make sure it is enabled by typing in the URL: "chrome://flags", and then search for "Developer tools experiments" and click enable.

2) In your project source file, in package.json, write as the property value "node --inspect ./bin/www" for the property "start".

3) In your terminal, type in "npm start".

4) To see it in Devtools, in a Chrome URL type "about://inspect" and click "Open dedicated DevlTools for Node".

Hope this helps.

  • Zane