Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

General Discussion

Ubuntu server. Anybody know?

A while back I installed ubuntu server on my old laptop. I put some webpages in var/www/index.html. That worked well! Now 4-5 weeks later I turn on my server again after it being off for 4-5 weeks. I've made some pages with my knowledge from treehouse and I wanted to have them on my server. I'm using putty to connect and log in and that works well. I also use filezilla to upload the files to it. Also works! But when I try to connect to the server( via 10.0.0.5 in google chrome witch I know is correct because I checked with the router Google chrome is saying this webpage is not available. Worked before, not know. I don't believe I have done any changes, but apperantly I must have... Have anybody experienced the same and have a solution for it? Nick Pettit Jason Seifer Guil Hernandez ??

7 Answers

Stone Preston
Stone Preston
42,016 Points

is the server on? is there anywhere you can press "start server" or something similar. not familiar with it so just a shot in the dark really.

Server is on. I can access it through filezilla and putty. So there is a connection. I can add files to the server, but for some reason google chromeor any browser says this webpage is not available.

You might also try checking out the firewall to see if the port is blocked. Try telneting to the port and tell us the outcome.

Ports are open. Believe I used 80 or 22. I can access the server thorugh flezilla and add files to the server. But any browser just says this webpage is not available.

So what output did you get when you do: telnet 10.0.0.5 80

telnet 10.0.0.5 80 says: ssh-2.0-OpenSSH_6.6.1p1 Ubuntu-2ubuntu2

I have no idea what that means but I guess there is a connection? What do you think?

Edit: My server is running on ubuntu server on a old laptop. The os is the server. No vmware or virtualbox.

Looks like you have the ssh service running on port 80.

Try this: sudo vim /etc/ssh/sshd_config

What port is it set to at the top?

Both port 80 and 22 is open.

So...I tried restarting the apache2 server. This showed up. The apache server is holding on to the webpages, right? And if that can't be run, no webpages can be shown, right? alt text Guess that image embedding didn't work....Well here's the link: http://imgur.com/vgz38Et

Well... if ssh is taking up port 80 then... you will not be able to serve web pages through that port... If port 80 shows up in your sshd_config file, you will have to change it to port 22.