Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Quality Assurance Introduction to Selenium Test Drive Selenium Installation

Unable to install Chrome Driver - error code ELIFECYCLE

No matter where I install it, wither in my root, or my project folder, I get the same error.

ChromeDriver binary exists. Validating... ChromeDriver is already available at '/tmp/81.0.4044.69/chromedriver/chromedriver'. Copying to target path /usr/local/lib/node_modules/chromedriver/lib/chromedriver ChromeDriver installation failed Error: EACCES: permission denied, mkdir '/usr/local/lib/node_modules/chromedriver/lib/chromedriver' at Object.mkdirSync (fs.js:841:3) at copyIntoPlace (/usr/local/lib/node_modules/chromedriver/install.js:289:6) at processTicksAndRejections (internal/process/task_queues.js:97:5) at async install (/usr/local/lib/node_modules/chromedriver/install.js:63:5) { errno: -13, syscall: 'mkdir', code: 'EACCES', path: '/usr/local/lib/node_modules/chromedriver/lib/chromedriver' } npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! chromedriver@81.0.0 install: node install.js npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the chromedriver@81.0.0 install script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

No idea what this means.

I've attempted clearing the cache. Attempted to reinstall npm and node.

Any ideas will be great... I'm stumped at the first hurdle!

2 Answers

I had to install it manually after much uninstalling and reinstalling of packages.. Not sure if other steps in my troubleshooting helped but doing it manually ended being the solution for me: https://www.swtestacademy.com/install-chrome-driver-on-mac/

I also had to install it manually. These Windows instructions worked for me: http://jonathansoma.com/lede/foundations-2018/classes/selenium/selenium-windows-install/

I found this --- and it worked !

npm install chromedriver --chromedriver-force-download

no idea if this is the favorable option but its allowed me to proceed so I'll take it :)

did not work for me.... any other ideas?