Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

PHP

Unable to Vagrant Up on terminal

Im trying to set my local development enviromet set up with Laravel Homestead i installed VB and Vagrant and already brought the homestead VB by 'vagrant box add laravel/homestead' also clonned Homestead folder already and modified the yaml file set up my sites folder.

but when i try to run vagrant up this happens

There was an error while executing VBoxManage, a CLI used by Vagrant for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "-n", "/home/raguirre/.vagrant.d/boxes/laravel-VAGRANTSLASH-homestead/0.3.0/virtualbox/box.ovf"]

Stderr: 0%...
Progress state: VBOX_E_FILE_ERROR
VBoxManage: error: Appliance read failed
VBoxManage: error: Could not read OVF file 'box.ovf' (VERR_ACCESS_DENIED)
VBoxManage: error: Details: code VBOX_E_FILE_ERROR (0x80bb0004), component ApplianceWrap, interface IAppliance
VBoxManage: error: Context: "RTEXITCODE handleImportAppliance(HandlerArg*)" at line 307 of file VBoxManageAppliance.cpp

anyone has had this same problem or knows how to solve it? thanks in advance

BTW im using linux Ubuntu

Hampton Paulk

1 Answer

Never mind i just used ' sudo vagrant up'

and that worked somehow

Jeff Lemay
Jeff Lemay
14,265 Points

I know you found a solution but I wanted to say I had a lot of trouble setting up Vagrant/Laravel too. I think the videos need to show some common errors that people encounter instead of just running through a "perfect installation". The thing that finally solved my problems was "vagrant provision" after running "vagrant up". But I have no idea why that solved things.

i know Jeff Lemay, the installation process its kind of frustrating, it wouldnt be bad to have a workshop with installation processes in different operating systems, for me it's being a struggle everytime i try to install something new working with linux but at the end, linux turns out to be better than the others, i think teachers should consider linux too