Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Swift

Christopher Eadie
Christopher Eadie
7,039 Points

Vending Machine app - files are too old

I have downloaded the files for this app and they are Swift version 3.0 and Xcode does not like them. I have been able to migrate part of it but am still getting build errors ("SWIFT VERSION 3.0 is unsupported..."). Does anyone know how to fix this this?

1 Answer

Waylan Sands
PLUS
Waylan Sands
Courses Plus Student 5,823 Points

In xcode select the main (top) file in the left column which contains all the project files. In the next column make sure you select the file under Targets. Then on the menu bar in the middle section select build settings. Look down through the options to Swift compiler - Language and change the version to 5