Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Development Tools Introduction to Docker Why Docker? What is Docker?

Jonathan Grieve
MOD
Jonathan Grieve
Treehouse Moderator 90,956 Points

Verify Docker

I wonder if any Docker experts out there can verify if I have Docker installed?

Not long after installing for Windows 10 I got this message popup.

Unable to stop: The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: The specified module 'Hyper-V' was not loaded because no valid module file was found in any module directory.
at <ScriptBlock>, <No file>: line 79
   at Docker.Backend.HyperV.RunScript(String action, Dictionary`2 parameters) in C:\gopath\src\github.com\docker\pinata\win\src\Docker.Backend\HyperV.cs:line 177
   at Docker.Backend.ContainerEngine.Linux.DoStop() in C:\gopath\src\github.com\docker\pinata\win\src\Docker.Backend\ContainerEngine\Linux.cs:line 280
   at Docker.Backend.ContainerEngine.Linux.Start(Settings settings) in C:\gopath\src\github.com\docker\pinata\win\src\Docker.Backend\ContainerEngine\Linux.cs:line 122
   at Docker.Core.Pipe.NamedPipeServer.<>c__DisplayClass9_0.<Register>b__0(Object[] parameters) in C:\gopath\src\github.com\docker\pinata\win\src\Docker.Core\pipe\NamedPipeServer.cs:line 47
   at Docker.Core.Pipe.NamedPipeServer.RunAction(String action, Object[] parameters) in C:\gopath\src\github.com\docker\pinata\win\src\Docker.Core\pipe\NamedPipeServer.cs:line 145

Which was a little disconcerting. I sent the ctrash report away via the program but i couldn't make sense of it.

I'm not sure if we were meant to grab the test Dockerfile from the teachers notes (in fact, I don't think we were, but I wanted to poke in anyway and see if I could verify if Docker was working properly in Git Bash.

docker version

I got this....

Client:
 Version:      17.06.2-ce
 API version:  1.30
 Go version:   go1.8.3
 Git commit:   cec0b72
 Built:        Tue Sep  5 19:57:19 2017
 OS/Arch:      windows/amd64
error during connect: Get http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.30/version: o pen //./pipe/docker_engine: The system cannot find the file specified. In the de fault daemon configuration on Windows, the docker client must be run elevated to  connect. This error may also indicate that the docker daemon is not running.

It looks like it's recognising Docker but still has an error in there somewhere. Any thoughts? Thanks :)

3 Answers

Ari Misha
Ari Misha
19,286 Points

Hiya there! Maybe try installing Docker with Docker Toolbox? And I agree with Nico Trivelli actually on this one! I use Vagrant instead of Docker . Docker messes up with my machine a lot especially networks settings and IPv4 and IPv6.

Although it seems like you have successfully installed Docker on your machine. But an error happened with connected to the port. I can think of three solutions right now.

  • OPTION 1 : Get in your Power Shell or cmd and try these commands and restart your pc:
Net stop com.docker.service
Net start com.docker.service
  • OPTION 2 : Restart your pc and install your drivers for wifi and adjust the network settings.

  • OPTION 3 : There might be an issue with your port settings and you might wanna change your default settings to a port which is not in use.

~ Ari

nico dev
nico dev
20,364 Points

Sorry, I forgot to thank you about this.

When you wrote this, I didn't know about Vagrant.

Since then, I've never ever had a problem with it.

nico dev
nico dev
20,364 Points

Hi Jonathan Grieve ,

I hope I won't sound utterly negative on this, but I would not seriously recommend this Docker thing for Windows, unless you have a very specific need for it and no alternatives.

I am, like you, on Windows 10 and tried to make this work, but ended up finding out some interesting things. One of them being I cannot use it because I don't have access to Hyper-V (sounds like an augmented fuel, cool! :) ) in my computer, since that Hyper-V thing is only available for Windows 10 Enterprise, Professional, or Education.

Then I am not easy to give up, I also went to the source, and said, well look they may offer any kind of workaround or plainly say 'not allowed for Windows users, stay away!' (with some bad guy face and arms crossed). Guess what I found? Well, my friend, I found issues like this one (and others), still opened after an year, with solutions that work for some and not for others, and still reopening and closing after more than a year.

I know I run the risk of a lot of people hating for this one, but I have to say it, for me the funny thing is this is supposed to be the wonderful product that makes deployment for your apps multi-platform. Seriously? Buddies at Docker, I think you can't ever publish a product and say it's allowing other people to make things work on different platforms, when you're not able to (or maybe even interested in) making your own product install (not even work, just install) appropriately in one of the most widespread platforms of the world. Sorry, but this one really let me down, and I really don't recommend any Windows user to waste their time.

DISCLAIMER: Nothing to do with the instructor, which I think is a crack, and I really like him and his teaching, this is just a catharsis about this Docker thing, and hopefully a signal to divert for any Windows user out there. :)

nico dev
nico dev
20,364 Points

Sorry, I forgot to detail this:

Unable to stop: The running command stopped because 
the preference variable "ErrorActionPreference"
or common parameter is set to Stop: 
The specified module 'Hyper-V' was not loaded 
because no valid module file 
was found in any module directory.
at <ScriptBlock>, <No file>: line 79

That, in short, means: your Hyper-V module does not have any files, I can't continue so I abort here. Goodbye. :)

If your Windows 10 is Pro, Ent or Edu, please follow up here, because there's a way to enable it (from Apps and Features), although I'm not sure if the thing will work with stability later.

Jonathan Grieve
Jonathan Grieve
Treehouse Moderator 90,956 Points

Thanks for all your replies.

I'm starting to think you're right though. I've tried every trick offered here and by Google to try and get up and running.

I'm on Windows 10 Home.

The commands i've tried tell me

$ Net start com.docker.service
System error 5 has occurred.

Access is denied.

And even on the administrator command prompt

C:\WINDOWS\system32>Net stop com.docker.service
The Docker for Windows Service service is not started.

More help is available by typing NET HELPMSG 3521.


C:\WINDOWS\system32>NET HELPMSG 3521

The *** service is not started.



C:\WINDOWS\system32>NET HELPMSG 3521

The *** service is not started.



C:\WINDOWS\system32>cd c:/xamp/htdocs/docker

c:\xamp\htdocs\docker>Net start com.docker.service
System error 3 has occurred.

The system cannot find the path specified.


c:\xamp\htdocs\docker>

I may just give it a miss if it's too much hassle. :(

nico dev
nico dev
20,364 Points

Thanks for adding another answer, ryorke , however, I must be honest with you and tell you I can't agree with some parts of what you state.

This and this does not seem to really agree with the part where you affirm:

as most web developers working with these technologies use OSX or Linux-based machines.

Now, for the sake of clarification, let's suppose that almost everyone use either a Mac or Linux, is that supposed to mean that unless you use one you can't access tool for developers? Doesn't that almost sound like a closed circle, in which you only get access with an apple or a penguin in your laptop? Is that really what we should push forward to?

Isn't the Internet, and the Open Source, and so many other principles and things (like even using Babel, Modernizr and so on to make sites more accessible to everyone, also all of what aria offers in terms of accessibility, Caniuse and thinking of how to use each technology carefully in an unobtrusive way), isn't all of that about inclusion? About everyone having the same access? Unfortunately some guys (and I want to make it clear I'm not talking about you, unless you're part of Docker itself, for example) think they own the Internet and people's choices, which sounds a little bit arrogant to me.

However, Windows users will continue finding ways around when that happens, and at least that will hopefully make us more resourceful, although I wish that was not necessary.

Please don't take it personal, I just wanted to give some food for thought. You have your right to choose your Mac / Linux and I completely respect that.

Darrell Conklin
Darrell Conklin
21,786 Points

It's your beloved Windows who created those closed circles when they created different tiers of their OS excluding some important features in Home versions.