Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android Build a Simple Android App (retired 2014) Getting Started with Android Introduction to Methods and Classes

Virtual device running but app will not

I'm following along with the tutorial. It took over 30minutes for the virtual device to start and when it did it did not run the app. I tried to start the app again (using the 'play' button) making sure the xml was selected first - still no joy. It does not show any errors (except the one about the string) and nothing happens in the console tab. Any ideas?

2 Answers

Christian Townsdin
Christian Townsdin
1,535 Points

Has it ever worked before or is this the first time?

Try right clicking the package name, presumably "CrystallBall", and select Run As -> Android App.

Anything?

What is the error with the string?

Thanks Christian for getting back on this - kind of you to give your time. No this is the first time. The error with the string is the same as the error shown by the tutor: Description Resource Path Location Type [I18N] Hardcoded string "Enlighten Me!", should use @string resource activity_main.xml /CrystalBall/res/layout line 26 Android Lint Problem He said to ignore it and his runs.

Anyway; Update since then. I've had a go again (I can only assume that even though the ADB was running it still had some 'stuff' to do in the background. Because this time I got a question and I chose run as android app. That started text running in the console window which said the adb was fine - Well, I'll paste the info below. Bottom line is it says it's running but nothing happens on the emulator. If I enquire on the emulator (manage apps) it does not show the app running.

[2014-02-04 19:36:34 - CrystalBall] Android Launch! [2014-02-04 19:36:34 - CrystalBall] adb is running normally. [2014-02-04 19:36:34 - CrystalBall] Performing com.example.crystalball.MainActivity activity launch [2014-02-04 19:36:34 - CrystalBall] Automatic Target Mode: using existing emulator 'emulator-5554' running compatible AVD 'Android44' [2014-02-04 19:36:39 - CrystalBall] Uploading CrystalBall.apk onto device 'emulator-5554' [2014-02-04 19:36:43 - CrystalBall] Installing CrystalBall.apk... [2014-02-04 19:37:15 - CrystalBall] Success! [2014-02-04 19:37:16 - CrystalBall] Starting activity com.example.crystalball.MainActivity on device emulator-5554