Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Java Java Data Structures Efficiency! Implement Chooser UI

Mojo Waters
Mojo Waters
5,748 Points

What am I missing here...

Usually I keep track, but now I must say I am overwhelmed - maybe I just need a break.

But anyway. I follow in Eclipse not in workspaces. So I am getting a message that in SongBook class private Map<String,List<Song>> byArtist() { for (Song song: mSongs) { List<Song> artistSongs = byArtist.get(song.getArtist()); if(artistSongs == null) { artistSongs = new ArrayList<>(); byArtist.put(song.getArtist(), artistSongs); } getArtist() is not in Song class but getmArtists() should it not be that instead of getArtist()?


1 Answer

Jacob Bergdahl
Jacob Bergdahl
29,118 Points

Yes, rename getmArtists() to getArtists().