Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

HTML HTML Basics Structuring Your Content Semantic HTML: <header>, <footer> and <section>

Donald Loucks
Donald Loucks
1,686 Points

When i go to edit my code it is deleting what i had there previously very annoying what can i do to combat this?thanks

<ul> <li><ame</li>

Very late response and you've probably fixed this by now. I had a similar issue and i think that you might have toggled you "ins" key on your keyboard. There is 2 settings, one is what you are used to and the other deletes the next digit/letter as you type. If you just press it again it should go back to normal,

1 Answer

could you please show your code that you're having this issue with?

I will then be able to determine if it is a TreeHouse workspace bug or an error in your code


He might describe a bug I had once. I could not correctly delete any code. There was some bits of code stuck right behind the cursor and whenever I tried to delete something the workspace deleted code a few spaces apart from the cursor while still having some code stuck behind it.

Couldn't fix it and had to move on to the next lesson and a new workspace.

Donald Loucks
Donald Loucks
1,686 Points

I don't think it's either though. Say I have a line of code like <ul><li><name> if I where to go in front of name an start typing it will delete the characters as I type New ones. Hard to explain but I tried lol

<name> is not part of the HTML DOM

Without seeing your workspace and your browsers it's quite hard to figure out, however, there are a few things you can check:

If you pass all of the above can you let me know and I will raise as a potential bug with the workspace

Thank you