Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

HTML

When I preview, the images do not show. Only boxes with an "X" in them. Does my code look wrong?

This is my code:

... <!DOCTYPE html> <html> <head> <meta charset="utf-8"> <title>Seluah | Visuals and Propaganda</title> </head> <body> <header> <a href="index.html"> <h1>Seluah</h1> <h2>Visuals and Propaganda</h2> </a> <nav> <ul> <li><a href="index.html">Portfolio</a></li> <li><a href="about.html">About</a></li> <li><a href="contact.html">Contact</a></li> </ul> </nav> </header> <section> <ul> <li> <a href="img/21c.jpg"> <img src="img/21c.jpg" alt=""> <p>21c Show Art.</p> </a> </li> <li> <a href="img/jbnfull.jpg"> <img src="img/jbnfull.jpg" alt=""> <p>Album Sketch by J.Noble.</p> </a> </li> <li> <a href="img/gun.jpg"> <img src="img/gun.jpg" alt=""> <p>OSG Single.</p> </a> </li> <li> <a href="img/headliners.jpg"> <img src="img/headliners.jpg" alt=""> <p>Headliners w/Cheyenne</p> </a> </li> <li> <a href="img/home20.jpg"> <img src="img/home20.jpg" alt=""> <p>Home's 20th Anniversary.</p> </a> </li> <li> <a href="img/zbar.jpg"> <img src="img/zbar.jpg" alt=""> <p>Zanzabar.</p> </a> </li> </ul> </section> <footer> <p>© 2014 Andrew Peace.</p> </footer>
</body> </html> ...

Hi Andrew,

Can you post a snapshot of your workspace?

https://teamtreehouse.com/forum/workspace-snapshots

3 Answers

I can't see your workspace, but that's fine. Your problem lies in your image path, have you typed it in correctly ? If you could pace your code here it would help tremendously.

Raymon Oleaga
Raymon Oleaga
19,298 Points

Can't see your code but I am assuming the path of the link is probably incorrect. so double check that work post the code here.

Your code should look like this <section> <ul id="gallery"> <li> <a href="img/numbers-01.jpg"> <img src="img/numbers-01.jpg" alt=""> <p>Experimentation with colour and texture.</p> </a> </li> <li> <a href="img/numbers-02.jpg"> <img src="img/numbers-02.jpg" alt=""> <p>playing with blending modes in photoshop.</p> </a> </li> <li> <a href="img/numbers-06.jpg"> <img src="img/numbers-06.jpg" alt=""> <p>trying an 80s style of glows.</p> </a> </li> <li> <a href="img/numbers-09.jpg"> <img src="img/numbers-09.jpg" alt=""> <p>Drips created using photoshop brushes.</p> </a> </li> <li> <a href="img/numbers-12.jpg"> <img src="img/numbers-12.jpg" alt=""> <p>Creating shapes using repetition.</p> </a> </li>

    </ul>
  </section>