Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Development Tools Introduction to Git First Commits First Commits

When I tried to add my email address and name to Git the console returned a > symbol.

I was following this tutorial within the console after launching the Workspace. I followed all the steps within the tutorial but ran into an issue when I ran git config --global user.email "myemailaddress@emailaddress.com"

(I did of course replace with my own email).

When I hit enter the console no longer had the prompt treehouse:~/workspace$ Instead it had a greater than sign > and I couldn't get it to go away. In the end I tried ctrl + c which seemed to work but I then had to navigate back to the original directory.

How do I fix this in the future and what happened?

Thank you

1 Answer

That happens when you forget a closing quotation mark. The terminal thinks you want to add more to what you've written. You probably entered something like:

git config --global user.email "myemailaddress@emailaddress.com

Let me know if this helps!

Ah thank you! How would I exit that in the future?

When you see the > sign you can put in the missing closing quotation mark (then press enter) and the command will go through as it should! Like this:

git config --global user.email "myemailaddress@emailaddress.com
> "

I think the > sign can happen at other times as well. Just remember it means that there's something on the line you input that is considered not complete.