Android Build a Simple Android App with Java Getting Started with Android Running the Fun Facts Project

Michael Sander
Michael Sander
569 Points

when i wan to run the project, there is a error messege "VT-x disbale in BIOS" what should i do? thank you for your help

when i wan to run the project, there is a error messege "VT-x disbale in BIOS" what should i do? thank you for your help.

2 Answers

Jennifer Nordell
STAFF
Jennifer Nordell
Treehouse Staff

Hi there! You should enable virtualization in the BIOS. My guess is that you're working on a laptop. Most laptops have this disabled by default. Some laptops don't support it at all. You will need to check with the manufacturer of the laptop about the BIOS options and follow their instructions.

Be aware that you can seriously mess things up even at the hardware level by not heeding the advice of the manufacturer. Please read the documentation for your computer concerning the BIOS before adjusting anything there.

Hope this helps! :sparkles:

Linda de Haan
Linda de Haan
11,221 Points

It's really simple actually enabling the Intel Virtual Technology on your laptop. I have a Lenovo Ideapad y700 and had the same error. Using this YouTube video as a guide (https://www.youtube.com/watch?v=4Cv2Hj2PlQE) and looking up how to enabling it on an Ideapad, this is what I did:

  1. Completely shut down your laptop and turn it on again
  2. During startup press F2 repeatedly to get to the BIOS (might be a different key for your laptop, look it up)
  3. Here find Intel Virtualization Technology (it is set to disabled)
  4. Set this to enabled
  5. Then exit BIOS by hitting save & exit (again might be a different key for your laptop)
  6. Laptop starts up again and when you try to run the emulator now it should work