Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

JavaScript JavaScript Basics (Retired) Creating Reusable Code with Functions Giving Information to Functions

7,895 Points

Which is the correct way?

My code for this video is

function getArea(width, length, unit) { var area = (width*length) +" "+ unit; return area; } console.log(getArea (10,20,'sq ft'));

instead of:

function getArea(width, length, unit) { var area = (width*length); return area+" "+ unit; } console.log(getArea (10,20,'sq ft'));

They both works the same way. Is it any of them better than the other?

Thanks :)

To be honest, it all depends on how you like to layout your code. In my opinion, I prefer your method as it is easier to understand.

Keep up the good work ;) Alistair

1 Answer

There isn't really a "correct" way. They both output the same answer and work the same way. Now it's pretty much your choice of preference. Whatever way you like better.