Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Android Build an Interactive Story App The Model-View-Presenter Pattern Creating a Data Model

Why am I getting a naming error with: public String getshipType(){ return shipType;

I get the naming convention error for getshipType().

get + shipType... this is the convention, correct?

Spaceship.java
public class Spaceship {
  public String shipType;

  public String getshipType(){
    return shipType;
  };
};

1 Answer

Two things I would try. The name getshipType() does not follow the camelcase naming convention. It should be getShipType() the second thing I would do is return this.shipType;