Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Why do I keep getting an error at this point in the test driven development??????

This is how my bank_account_spec.rb file looks like... require 'minitest/autorun' require 'minitest/spec'

$:.unshift File.expand_path(File.dirname(FILE) + '/..')

require 'lib/bank_account'

describe BankAccount do


This is what I get on cmd... syntax error, unexpected tIDENTIFIER, expecting end-of-input Help anyone???

1 Answer

Jason Seifer
Jason Seifer
Treehouse Guest Teacher

I think you have a slight misspelling here. Try changing:




Hey, Thanks for your response. I tried what you suggested but I still get the same error. I also tried just require 'minitest/autorun' require 'minitest/spec' ...am not sure what that has to do with anything, but I still get the same error. Any suggestions?

Jason Seifer
Jason Seifer
Treehouse Guest Teacher

Can you drop a link to your code on GitHub? That will make it easier to troubleshoot.