Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

JavaScript

Justin LeFurjah
Justin LeFurjah
12,347 Points

Why does it say that task 1 is no longer passing, when it worked a second ago and nothing has been changed?

So here is the deal: I get an error message about task 1 not passing, although it just worked and nothing has been changed, if I give a wrong answer to task 2.

Shouldn't it tell me that task 2 is wrong?

Here is a link to task 1 working:

http://i.imgur.com/CokWjYc.png

Here is a link to task 2 (deliberately) not working.

http://i.imgur.com/3lqmjJT.png

As far as I can tell, nothing that has been done in task 2 should be of consequence to the code from task one.

Can someone please explain to me why this is not a bug?

Thanks!

p.s. Here is a link to the test in question: http://teamtreehouse.com/library/creating-arrays

Although this

1 is right 2 is wrong therefore 1 is wrong

logic can be found in other tasks in the JS Foundations course.

1 Answer

Austin Whipple
Austin Whipple
29,687 Points

I've noticed that script errors on subsequent tasks will throw errors claiming that you broke the first one, when really it's just that the entire script is wrong and it blames it on the first item. Try it with an empty or valid array and see if that helps.

Justin LeFurjah
Justin LeFurjah
12,347 Points

Yeah I can get it to work. That's not the problem. I just think it is a bug (and reported it as one) hoping to get a shiny new badge :), but Treehouse said it wasn't a bug and to post to the forum so that the explanation of why it isn't a bug will be useful for others.

From the way you describe your experience with the same thing, it seems like you see it as a bug as well.