Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

JavaScript JavaScript Array Iteration Methods Array Manipulation Practice reduce()

Why my code is not working here using includes()? Thanks

phoneNumbers is array of 10 digit phone numbers, where the first three digits, in parentheses, are area codes. Using reduce, return the total phone numbers with a 503 area code. Store the total in the variable numberOf503.

app.js
const phoneNumbers = ["(503) 123-4567", "(646) 123-4567", "(503) 987-6543", "(503) 234-5678", "(212) 123-4567", "(416) 123-4567"];
let numberOf503;

// numberOf503 should be: 3
// Write your code below

phoneNumbers.reduce((count,areaCode)=>{
  if(areaCode.includes('(503)')){
    count+=1
  }
  return count;
},0);

1 Answer

Hi Hanwen!

Your biggest issue is just not doing the last step (storing the value produced by the reduce method).

The giveaway is that numberOf503 has been declared, but you haven't used it.

This passes:

const phoneNumbers = ["(503) 123-4567", "(646) 123-4567", "(503) 987-6543", "(503) 234-5678", "(212) 123-4567", "(416) 123-4567"];
let numberOf503;

// numberOf503 should be: 3
// Write your code below

numberOf503 = phoneNumbers.reduce((count, phoneNumber) => { // This is what was missing
  if(phoneNumber.includes('(503)')){
    count += 1;
  }
  return count;
},0);

The rest of your code what correct.

I just changed areaCode to phoneNumber, because to me, it's more accurate, semantically.

I hope that helps.

Stay safe and happy coding!

Got it, thank you Peter