Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

JavaScript

Why not just use "Value" in the for in loop?

Hi, Was just wondering, if we are trying to access the value of a key within an object, why not just name it "Value" like this:

//to access key in Person object
for (let key in person) {
    console.log(key)
}

//to access value in Person object
for (let value in person) {
    console.log(person[value])
}

Instead of naming it prop, seems a bit more confusing since it reads as if we are trying to access the key/property rather than the value.

Im asking this cus I want your opinion, don't you think it reads better too? or is it just me?

Thank you!