Welcome to the Treehouse Community
The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)
Looking to learn something new?
Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.
Why use an alias for genres.name? Isn't using a keyword as a column name bad practice?
Instead, why not assign the "name" column in the genres table a more descriptive title like "genre" or "genre_name"?
name doesn't seem to actually be a reserved word.
names is in some SQL languages.
But since it's aliased as genre_name, that seems sufficient.
It probably would be best to make things more descriptive to avoid any conflicts though. I know that it's common to do that for ID fields, instead of having a field in every table called