Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Wordpress Widget 'Oops! That page can’t be found.' - Error 404

When i click Appearance > Widget on my wordpress admin dashboard it brings me to my website url: http://www.caradesain.com/wp-admin/widgets.php with a message saying: 'Oops! That page can’t be found.' - Error 404

4 Answers

Have you updated or moved your site recently? Whenever I have seen this it is typically a broken core install. If you browse your install and go to the wp-admin folder, is there a file in there called widgets.php?

Hi Luke,

Thank you for your reply.

I didn't edit any of my core files like html, .php code or move my site recently. When i go to my file manager, the widgets.php is still there, i never move or edit the file before.

Next step would be to disable any plugins you have, one at a time, checking each time to see if the page comes back up. Sometimes a plugin can cause that to happen. What theme are you using by chance?

Hi Luke, thanks again for your response. I tried deactivating all my plugins, but the problem still persist. Do you have any other solution? I'm using Armada from Dream theme.

If you switch themes to a default install like TwentySixteen, does it load?

I've tried switching to TwentySixteen Theme, my widget still showing up as "not found". What should i do now?

Whenever I run into a situation like that I backup the site, delete wp-admin and wp-includes, leaving wp-content alone (don't delete that one!). Then I download a fresh copy of WP and copy both the wp-admin and wp-includes folder for the newest version and place them back into my website.

It is possible a part of the core install was corrupted somehow when it was installed. After that I might contact your web host and see if there is anything on their end breaking the functionality.