Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Python

Works in Workspaces/visualizer but not in Code Challenge

It appears my ability to take/share snapshots is also not working. https://w.trhou.se/eo3yzznyez

Please click for a screenshot instead: https://imgur.com/Ci6rXDd

https://teamtreehouse.com/library/python-basics/shopping-list-app/continue Task 1 of 1

4 Answers

Steven Parker
Steven Parker
230,024 Points

The code appears to be correct, perhaps there's some invisible character in the code?

For future questions, try the "get help" button in the challenge, it should format the code and paste it into the question for you, and also add a link button for the challenge.

Also, you might want to report that blank snapshot to the Support folks. I've seen two others like it today, there might be some issue that isn't showing up on the status page.

Jason Anders
MOD
Jason Anders
Treehouse Moderator 145,858 Points

Hey there,

I sorry it took a bit to respond to your request.

Steven is right in that your code is correct. If you still haven't resolved this issue, try restarting the challenge and beginning again. The code checker can be very picky... and sometimes they do glitch. But, there is nothing wrong with your code. Nice Work! :thumbsup:

The problem may lie in your 'zero' index character. I notice the 0 has a dot in the centre. I'm going to assume that you copy / pasted from an editor into the challenge? If you did, that's probably the issue. Editors, WPs, etc often use 'fancy' characters that the code checker doesn't recognize. This happens mostly with fancy quotes, but who knows. Try manually typing in the answer. If that doesn't work, let me know.

:) :dizzy:

Steven Parker
Steven Parker
230,024 Points

The dot might just be the way zero is distinguished from capital "O" in that font.

OK it worked now. I did try restarting the challenge last night and retyping the code from scratch but to no avail. Tried it today and somehow worked. The zero with the dot in the middle was still there for the one I that got accepted. We'll never know the reason why it didn't work in the first place...