Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

HTML How to Make a Website CSS: Cascading Style Sheets Use ID Selectors

Donald Hobson
Donald Hobson
691 Points

Workspace Showing Error Between </header> and both </body> and </html>

Hi,

My workspace is showing errors between </header> and both </body> and </html>, like something is not closed. All of these closing tags are highlighted in red on my work space.

I have been comparing this to the video and trying to find the error for two hours. Another pair of eyes would help, I can not find it.

Any help would be great! Thanks.

<!DOCTYPE html>
<html>
  <head>
    <meta charset="utf-8">
    <title> Don H | Designer</title>
    <link rel="stylesheet" href="css/normalize.css">
    <link rel="stylesheet" href="css/main.css">
   </head>
   <body>
    <header>
      <a href="index.html">
        <h1>Don</h1>
        <h2>Designer</h2>
      <a/>
      <nav>
        <ul>
          <li><a href ="index.html">Portfolio</a></li>
          <li><a href="about.html">About</a></li>
          <li><a href="contact.html">Contact</a></li>
        </ul>
      </nav>
    </header>
    <div id="wrapper">
      <section>
        <ul>
         <li>
           <a href="img/numbers-01.jpg">
             <img src="img/numbers-01.jpg"alt="">
             <p>Experimentation with color and texture</p>
           </a>
         </li>
         <li>
           <a href="img/numbers-02.jpg">
             <img src="img/numbers-02.jpg"alt="">
             <p>Playing With Blending Modes and Photoshop</p>
           </a>
         </li>
         <li>
           <a href="img/numbers-06.jpg">
             <img src="img/numbers-06.jpg"alt="">
             <p>Trying to Create an 80's Stlye of Glows</p>
           </a>
         </li>
         <li>
           <a href="img/numbers-09.jpg">
             <img src="img/numbers-09.jpg"alt="">
             <p>Drips Created Using Photoshop Brushes</p>
           </a>
         </li>
         <li>
           <a href="img/numbers-12.jpg">
             <img src="img/numbers-12.jpg"alt="">
             <p>Creating Shapes Using Repetition</p>
           </a>
         </li>   
        </ul>
      </section>
      <footer>
       <a href="http://twitter.com"><img src="img/twitter-wrap.png"alt="Twitter Logo"></a>
       <a href="http://facebook.com"><img src="img/facebook-wrap.png"alt="Facebook Logo"></a>
       <p>&copy; 2017 Don H.</p>
      </footer>
    </div>
  </body> 
</html>

1 Answer

Steven Parker
Steven Parker
218,692 Points

You have a malformed end tag.

The end tag for the link just before the nav should be "</a>", but you have "<a/>".

Donald Hobson
Donald Hobson
691 Points

It worked Steven!!! Thanks so much!!!!