Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Development Tools Introduction to Git First Commits First Commits

Workspaces: Macbook Pro Keyboard Input Issues

I've just noticed when trying to enter the git commit command that I can't actually enter quotation marks into the workspace console.

eg: git commit -m "commit text"

Because I can't enter those quotation marks I can't enter the actual command in the Workspace Console. Just wondering if anyone is having this issues. Otherwise I'll likely switch to a windows machine to finish this up.

1 Answer

Jay McGavren
STAFF
Jay McGavren
Treehouse Teacher

Strange. Are you on a non-US keyboard layout? Single quotes (') should work as well, can you try those?

I’m working on the standard US Keyboards layout. I’ll take a look at single quotes when I get home. Thanks for the advice.

Sorry for the delay in getting back to you, no such luck with single (') or double (") quotation marks within the Workspace Console. Tested in Chrome and Safari.

Very odd, but I'm assuming this is isolated to me, no browser extensions running with exception of a password manager.

Did a sanity check and I am indeed using a US Keyboard layout.

Jay McGavren
Jay McGavren
Treehouse Teacher

James Jenkins That is strange indeed. I de-emphasize this in the course, but you might also try leaving the -m option and the commit message off, and write a commit message using the editor ("nano" under our defaults).

Cheers Jay, I'll probably switch over to PC to do the course. Otherwise thanks for the help :)