Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Daniel Racowsky
Daniel Racowsky
1,574 Points

XAMPP issues: Apache won't start

I am working through the local Wordpress Dev tutorial. I have downloaded and opened XAMPP, however, Apache simply will not start. It seems I have exhausted every troubleshooting recommendation Google and these forums offer, and still no go.

The error:

8:59:44 PM [Apache] Error: Apache shutdown unexpectedly. 8:59:44 PM [Apache] This may be due to a blocked port, missing dependencies,

8:59:44 PM [Apache] improper privileges, a crash, or a shutdown by another method.

I would greatly appreciate any guidance you're able to provide.

Thank you. Daniel

3 Answers

Could be a number of things. What operating system and version of xampp are you using?

Some things you could try if you haven't already:

  • Maybe your firewall is blocking it? Try adding to whitelist/list of allowed programs.

  • Is there anything running on port 80? check out this stackoverflow thread - there's some good posts there mentioning issues with skype, as well as how to check/stop what's running on port 80.

  • Also check out this article on changing the port number

  • You could also try posting on the apache friends support forum and see if anyone can help you there.

Hope this helps!

Chris Shaw
Chris Shaw
26,676 Points

Hi Daniel,

If you have Skype installed go to Tools -> Options -> Advanced -> Connection and disable Use port 80 and 443 for alternatives for incoming connections, exit Skype and you should be good to go.

NOTE: Sometimes you may need to restart your PC

Daniel Racowsky
Daniel Racowsky
1,574 Points

Awesome! Your third bullet worked! Thanks, both!!